Related Posts with Thumbnails
Twitter Delicious Facebook Digg Stumbleupon Favorites More

Wednesday, January 19, 2011

Jenis Parameter yang digunakan BGP untuk Routing

BGP (Border Gateway Protocol) menggunakan beberapa parameter dalam mengambil keputusan jalur mana yang dipakai untuk mengirimkan data yaitu:

  • Weight, merupakan parameter dari router itu sendiri mengenairouting mana yang hendak dipilih. Weight diberikan kesebuah router dan hanya digunakan pada router itu sendiri. Semakin tinggi nilai weight dari sebuah router maka semakin baik jalur routing melalui router tersebut.
  • Local Preference, merupakan parameter lain yang digunakan dalam pemilihan jalur routing. Berbeda dengan weight yang hanya digunakan sendiri oleh router, local preference
    digunakan bersama antar router iBGP tetapi tidak dapat digunakan secara bersama pada router eBGP. Default nilai local preference adalah 100, semakin tinggi nilai local preference menunjukkan semakin baiknya jalur routing tersebut.
  • Multi-Exit Descriminator (MED), menggambarkan kondisi jalur yang kita miliki ke router eksternal. Lain halnya dengan weight dan local preference, MED meninggalkan jaringan kita dan menceritakan ke neighbor jalur routing mana yang ingin kita gunakan. Default nilai MED adalah 0, semakin kecil nilai MED menunjukkan semakin baiknya jalur routing.
  • Origin, merupakan gambaran sebuah jalur routing berasal dari protokol IGP, EGP, atau redistribusi dari protokol lain. Origin dari protokol IGP memiliki nilai 0, protokol EGP
    memiliki nilai 1, sedangkan hasil redistribusi dari protokol lain dianggap incomplete dan memiliki nilai origin 2.
  • AS-PATH, jalur routing BGP berdasarkan pada daftar autonomous system yang harus dilewati untuk mencapai sebuah alamat tujuan. Jalur routing yang dipilih adalah jalur routing dengan AS-PATH paling pendek. Dengan AS-PATH memungkinkan BGP mendeteksi adanya routing loop.
BGP hanya memilih sebuah jalur routing untuk mencapai sebuah alamat tujuan. Jalur routing ini ditambahkan ke dalam tabel routing dan didistribusikan ke BGP peers (neighbor).

Autonomous System

Autonomous System atau yang disingkat AS adalah suatu kelompok yang terdiri dari satu atau lebih IP Prefix yang terkoneksi yang dijalankan oleh satu atau lebih operator jaringan dibawah satu kebijakan routing yang didefinisikan dengan jelas. AS diperlukan bila suatu jaringan terhubung ke lebih dari satu AS yang memiliki kebijakan routing yang berbeda. Contoh yang paling sering dijumpai adalah: jaringan yang terhubung kepada dua upstream atau lebih ataupun eXchange Point, peering dengan jaringan lokal pada eXchange Point. Autonomous System Number atau yang disingkat ASN adalah nomor two-byte unik yang diasosiasikan dengan AS. ASN digunakan sebagai pengidentifikasi yang memungkinkan AS untuk saling menukar informasi routing dinamik dengan AS yang lain. Protokol routing eksterior seperti Border Gateway Protocol (BGP) membutuhkan ASN untuk saling bertukar informasi antara jaringan.


source : http://id.wikipedia.org/wiki/Autonomous_System

BGP (Border Gateway Protocol)

Border Gateway Protocol disingkat BGP adalah inti dari protokol routing Internet. Protocol ini yang menjadi backbone dari jaringan Internet dunia. BGP adalah protokol routing inti dari Internet yg digunakan untuk melakukan pertukaran informasi routing antar jaringan.

Border Gateway Protocol (BGP) merupakan protokol routing antar Autonomous System (AS). Autonomous System (AS), mengacu pada dokumen IETF RFC 1930 didefinisikan sebagai kumpulan router-router pada satu pengelolaan administrative yang menggunakan IGP sebagai protokol routing dalam AS tersebut dan menggunakan EGP sebagai protokol routing ke AS lain. Nomor AS dimulai dari 1 sampai 65535 dengan catatan nomor AS 64512 sampai 65535 digunakan sebagai nomor AS private. Walaupun BGP merupakan protokol routing EGP yang merouting paket data antar AS tetapi BGP juga mendukung proses routing paket data dalam sebuah AS. Berdasar pada nomor AS yang digunakan dalam proses routing, BGP dikategorikan menjadi dua, yaitu:
  • Internal BGP (iBGP) merupakan proses pertukaran informasi routing dalam sebuah AS.
  • Eksternal BGP (eBGP) merupakan proses pertukaran informasi routing BGP antar router-router di internet yang berbeda AS.
BGP merupakan protokol routing yang memanfaatkan TCP port 179 untuk pertukaran informasi routing antar router.

RIP (Routing Information Protocol)

Sedikit berbagi informasi tentang RIP. Apa itu RIP ?

RIP adalah protokol routing dinamik yang berbasis distance vector. RIP menggunakan
protokol UDP pada port 520 untuk mengirimkan informasi routing antar router. RIP
menghitung routing terbaik berdasarkan perhitungan HOP. RIP membutuhkan waktu untuk
melakukan converge. RIP membutuhkan power CPU yang rendah dan memory yang kecil
daripada protokol yang lainnya.

  • SEJARAH
Algoritma routing yang digunakan dalam RIP, algoritma Bellman-Ford, pertama kali digunakan dalam jaringan komputer pada tahun 1968, sebagai awal dari algoritma routing ARPANET.
Versi paling awal protokol khusus yang menjadi RIP adalah Gateway Information Protocol, sebagai bagian dari PARC Universal Packet internetworking protocol suite, yang dikembangkan di Xerox Parc. Sebuah versi yang bernama Routing Information Protocol, adalah bagian dari Xerox Network Services.
Sebuah versi dari RIP yang mendukung Internet Protocol (IP) kemudian dimasukkan dalam Berkeley Software Distribution (BSD) dari sistem operasi Unix. Ini dikenal sebagai daemon routed. Berbagai vendor lainnya membuat protokol routing yang diimplementasikan sendiri. Akhirnya, RFC 1058 menyatukan berbagai implementasi di bawah satu standar.

RIP memiliki beberapa keterbatasan, antara lain:
1. METRIC: Hop Count
RIP menghitung routing terbaik berdasarkan hop count dimana belum tentu hop count
yang rendah menggunakan protokol LAN yang bagus, dan bisa saja RIP memilih jalur
jaringan yang lambat.
2. Hop Count Limit
RIP tidak dapat mengatur hop lebih dari 15. hal ini digunakan untuk mencegah loop
pada jaringan.
3. Classful Routing Only
RIP menggunakan classful routing ( /8, /16, /24 ). RIP tidak dapat mengatur classless
routing.



Ada tiga versi dari Routing Information Protocol: RIPv1, RIPv2, dan RIPng, yaitu :

  • RIP versi 1
Spesifikasi asli RIP, didefinisikan dalam RFC 1058, classful menggunakan routing. Update routing periodik tidak membawa informasi subnet, kurang dukungan untuk Variable Length Subnet Mask (VLSM). Keterbatasan ini tidak memungkinkan untuk memiliki subnet berukuran berbeda dalam kelas jaringan yang sama. Dengan kata lain, semua subnet dalam kelas jaringan harus memiliki ukuran yang sama. Juga tidak ada dukungan untuk router otentikasi, membuat RIP rentan terhadap berbagai serangan.

  • RIP versi 2
Karena kekurangan RIP asli spesifikasi, RIP versi 2 (RIPv2) dikembangkan pada tahun 1993 dan standar terakhir pada tahun 1998. Ini termasuk kemampuan untuk membawa informasi subnet, sehingga mendukung Classless Inter-Domain Routing (CIDR). Untuk menjaga kompatibilitas, maka batas hop dari 15 tetap. RIPv2 memiliki fasilitas untuk sepenuhnya beroperasi dengan spesifikasi awal jika semua protokol Harus Nol bidang dalam pesan RIPv1 benar ditentukan. Selain itu, aktifkan kompatibilitas fitur memungkinkan interoperabilitas halus penyesuaian.

Dalam upaya untuk menghindari beban yang tidak perlu host yang tidak berpartisipasi dalam routing, RIPv2 me-multicast seluruh tabel routing ke semua router yang berdekatan di alamat 224.0.0.9, sebagai lawan dari RIP yang menggunakan siaran unicast. Alamat 224.0.0.9 ini berada pada alamat IP versi 4 kelas D (range 224.0.0.0 - 239.255.255.255). Pengalamatan unicast masih diperbolehkan untuk aplikasi khusus.

(MD5) otentikasi RIP diperkenalkan pada tahun 1997.

RIPv2 adalah Standar Internet STD-56.
  • RIPng

RIPng (RIP Next Generation / RIP generasi berikutnya), yang didefinisikan dalam RFC 2080 adalah perluasan dari RIPv2 untuk mendukung IPv6, generasi Internet Protocol berikutnya.


Perbedaan utama antara RIPv2 dan RIPng adalah:

  • Dukungan dari jaringan IPv6.
  • RIPv2 mendukung otentikasi RIPv1, sedangkan RIPng tidak. IPv6 router itu, pada saat itu, seharusnya menggunakan IP Security (IPsec) untuk otentikasi.
  • * RIPv2 memungkinkan pemberian beragam tag untuk rute , sedangkan RIPng tidak;
  • RIPv2 meng-encode hop berikutnya (next-hop) ke setiap entry route, RIPng membutuhkan penyandian (encoding) tertentu dari hop berikutnya untuk satu set entry route .


Source : http://id.wikipedia.org/wiki/Routing_Information_Protocol

Monday, January 17, 2011

RARP (Reverse Address Resolution Protocol)

Reverse Address Resolution Protocol (RARP) adalah protokol jaringan usang komputer yang digunakan oleh komputer host untuk meminta perusahaan Internet Protocol ( IPv4 ) alamat dari suatu host administrasi, ketika telah yang tersedia Link Layer atau alamat perangkat keras, seperti MAC address.

RARP is described in Internet Engineering Task Force (IETF) publication RFC 903 . [ 1 ] It has been rendered obsolete by the Bootstrap Protocol (BOOTP) and the modern Dynamic Host Configuration Protocol (DHCP), which both support a much greater feature set than RARP. RARP digambarkan dalam Internet Engineering Task Force (IETF) Pengumuman RFC 903 . [1] Ia telah dianggap usang oleh Bootstrap Protocol (BOOTP) dan modern Dynamic Host Configuration Protocol (DHCP), yang mendukung kedua fitur yang jauh lebih besar daripada yang ditetapkan RARP.

RARP requires one or more server hosts to maintain a database of mappings of Link Layer addresses to their respective protocol addresses. Media Access Control (MAC) addresses needed to be individually configured on the servers by an administrator. RARP membutuhkan satu atau lebih host server untuk memelihara database pemetaan Link Layer alamat protokol masing-masing alamat mereka. Media Access Control (MAC) alamat yang diperlukan untuk secara individual dikonfigurasi pada server oleh administrator. RARP was limited to serving only IP addresses . RARP terbatas untuk melayani hanya alamat IP .

Reverse ARP differs from the Inverse Address Resolution Protocol (InARP) described in RFC 2390 , which is designed to obtain the IP address associated with another host's MAC address. Reverse ARP berbeda dari Inverse Address Resolution Protocol (InARP) dijelaskan dalam RFC 2390 , yang dirancang untuk mendapatkan alamat IP yang terkait dengan MAC address host lain. InARP is the complement of the Address Resolution Protocol used for the reverse lookup. InARP adalah pelengkap dari Address Resolution Protocol digunakan untuk reverse lookup.

Sesungguhnya RARP didisain untuk memecahkan masalah mapping alamat dalam sebuah mesin/komputer di mana mesin/komputer mengetahui alamat fisiknya namun tidak mengetahui alamat logikanya. Cara kerja RARP ini terjadi pada saat mesin seperti komputer atau router yang baru bergabung dalam jaringan lokal, kebanyakan tipe mesin yang menerapkan RARP adalah mesin yang diskless, atau tidak mempunyai aplikasi program dalam disk. RARP kemudian memberikan request secara broadcast di jaringan lokal. Mesin yang lain pada jaringan lokal yang mengetahui semua seluruh alamat IP akan akan meresponsnya dengan RARP reply secara unicast. Sebagai catatan, mesin yang merequest harus menjalankan program klien RARP, sedangkan mesin yang merespons harus menjalankan program server RARP.

ARP (Address Resolution Protocol)

sebuah protokol dalam TCP/IP Protocol Suite yang bertanggungjawab dalam melakukan resolusi alamat IP ke dalam alamat Media Access Control (MAC Address). ARP didefinisikan di dalam RFC 826

ARP berasosiasi antara alamat fisik dan alamat IP. Pada LAN, setiap device, host, station dll diidentifikasi dalam bentuk alamat fisik yang didapat dari NIC.

Setiap host atau router yang ingin mengetahui alamat fisik daripada host atau router yang terletak dalam jaringan lokal yang sama akan mengirim paket query ARP secara broadcast, sehingga seluruh host atau router yang berada pada jaringan lokal akan menerima paket query tersebut. Kemudain setiap router atau host yang menerima paket query dari salah satu host atau router yang mengirim maka akan diproses hanya oleh host atau router yang memiliki IP yang terdapat dalam paket query ARP. Host yang menerima respons akan mengirm balik kepada pengirim query yang berisi paket berupa informasi alamat IP dan alamat fisik.

Ketika sebuah aplikasi yang mendukung teknologi protokol jaringan TCP/IP mencoba untuk mengakses sebuah host TCP/IP dengan menggunakan alamat IP, maka alamat IP yang dimiliki oleh host yang dituju harus diterjemahkan terlebih dahulu ke dalam MAC Address agar frame-frame data dapat diteruskan ke tujuan dan diletakkan di atas media transmisi (kabel, radio, atau cahaya), setelah diproses terlebih dahulu oleh Network Interface Card (NIC). Hal ini dikarenakan NIC beroperasi dalam lapisan fisik dan lapisan data-link pada tujuh lapis model referensi OSI dan menggunakan alamat fisik daripada menggunakan alamat logis (seperti halnya alamat IP atau nama NetBIOS) untuk melakukan komunikasi data dalam jaringan.


Jika memang alamat yang dituju berada di luar jaringan lokal, maka ARP akan mencoba untuk mendapatkan MAC address dari antarmuka router lokal yang menghubungkan jaringan lokal ke luar jaringan (di mana komputer yang dituju berada).

Simple Network Management Protocol (SNMP)

Simple Network Management Protocol (SNMP) merupakan protokol standard industri yang digunakan untuk memonitor dan mengelola berbagai perangkat di jaringan Internet meliputi hub, router, switch, workstation dan sistem manajemen jaringan secara jarak jauh (remote). Baru-baru ini (pertengahan Februari 2002) Oulu University Secure Programming Group, sebuah group riset keamanan jaringan di Finlandia, telah menemukan adanya kelemahan (vulnerability) pada SNMP v1.

Kelemahan tersebut memungkinkan seorang cracker memasang back door pada peralatan yang menggunakan SNMP v1 sehingga bisa menyusup ke jaringan dan melakukan apa saja terhadap jaringan. Kelemahan ditemukan pada SNMP trap and request facilities yang memungkinkan penyusup memperoleh akses ke dalam sistem yang menjalankan SNMP dan melakukan serangan Denial of Service (DoS) yang membuat sistem tidak berfungsi (down) atau tidak stabil.

SNMP v1 telah dipakai sejak awal tahun 1980-an. Terdapat berbagai usaha untuk memperbaiki standard SNMP yaitu dengan munculnya SNMP v2 dan SNMP v3 pada tahun 1998. Namun usaha ini tidak begitu berhasil. Sebagian besar jaringan saat ini masih menggunakan SNMP v1.

Masalah ini cukup merepotkan karena tidak hanya menyangkut satu jenis peralatan dari satu vendor melainkan menyangkut perangkat dari berbagai banyak vendor sehingga diperlukan patch/update dari berbagai vendor yang peralatannya menggunakan SNMP v1.

Untuk mengatasi kelemahan pada SNMP ini CERT Coordination Center (www.cert.org), suatu pusat pengembangan dan riset keamanan Internet, merekomendasikan untuk sementara menutup jalan masuk (ingress filtering) trafik SNMP pada port 161/udp dan 162/udp. Jika hal ini tidak mungkin dilakukan, CERT menyarankan untuk membatasi trafik SNMP hanya pada Virtual Private Noetwork (VPN) atau mengisolasi sistem manajemen jaringan dari jaringan publik. Penutupan port dilakukan sementara sambil menunggu dikeluarkannya pacth/update dari pihak vendor yang membuat perangkat yang menggunakan SNMP v1 tersebut.